Error SMTP

Uno de estos días ante un problema con un cliente tuve que ponerme a investigar, pues un formulario en DRUPAL que trabajaba con un módulo SMTP para enviar correos, dejó de funcionar en este caso mostrando el siguiente error

SMTP -> ERROR: Failed to connect to server: Connection refused (111)

El ambiente como contaba era un Drupal, en este caso instalado en un servidor Linux con cPanel/WHM.

Al hacer varios chequeos y revisar logs veo que puede haber algún tipo de bloqueo en el firewall del servidor, por lo que lo deshabilito y eureka, ya los envíos se hacen sin problemas. Vuelvo a habilitar y buscando opciones de SMTP en la configuración del firewall me encuentro con este parámetro

SMTP_ALLOWUSER

al que inmediatamente le agrego el usuario del hosting y listo, ya quedó el problema resuelto y el formulario enviando de nuevo.

Seguramente el problema se dió con alguna actualización de seguridad del servidor.

spacer